IT資訊
當前位置:草根網 > IT資訊 >  虛擬化

文言文亦能編程,該項目在GitHub摘得5500星

2019-12-31 16:59:12 IT之家 騎士 編輯:草根 瀏覽數:33草根網

IT之家12月18日消息 有中國開發者上傳的文言文編程語言項目已經在GitHub上摘得了5500星,你可知如何用文言文輸出“Hello World”?吾有一言。曰「「問天地好在?!埂?。書之。據悉,該文言文編程語言來自CM...

IT之家12月18日消息 有中國開發者上傳的文言文編程語言項目已經在GitHub上摘得了5500星,你可知如何用文言文輸出“Hello World”?吾有一言。曰「「問天地好在?!埂?。書之。

據悉,該文言文編程語言來自CMU本科生Huang Lingdong??删幾g成Javascript,也可編譯成Python,亦有線上編輯器 (IDE) 可直接運行。

GitHub地址:https://github.com/LingDong-/wenyan-lang

夫唐、虞之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械之巧,精於公輸之木鳶,善於武侯之流馬;程式語言之多,繁若《天官》之星宿,奇勝《山經》之走獸。鼠、蟹、鑽、魚,或以速稱。蛇、象、駱、犀,各爭文采。方知鬼之所以夜哭,天之所以雨粟。然以文言編程者 ,似所未有。此誠非文脈之所以傳,文心之所以保。嗟予小子,遂有斯志。然則數寸之烏絲猶覆於頭,萬卷之素書未破於手;一身長羈于遠邦,兩耳久曠于雅言。然夫文章者吾之所宿好,程式者偶承時人之謬譽。故希孟不慚年少,莊生不望無涯。乃作斯言。誠未能嘔瀝長吉之心血,亦庶幾免於義山之流沫。既成之後,復學干將鑄劍而自飼,越王嚐糞而當先。自謂偶追《十書》之筆意,但恨少八家之淋漓。此子山所謂士衡撫掌而甘心,平子見陋而固宜。然則雖實覆甕之質,尚存斧正之望;雖乏呂相之金,易字之渴蓋同。此亦開源之大義,吾輩之所以勉勵也。一笑。

Hello world

Wenyan:

吾有一數。曰三。名之曰「甲」。
為是「甲」遍。
吾有一言。曰「「問天地好在?!埂?。書之。
云云。

Equivalent JavaScript:

var n = 3;
for (var i = 0; i < n; i++) {
console.log("問天地好在。");
}

Output:

問天地好在。 
問天地好在。 
問天地好在。

Punctuations and newlines are completely optional (just like they are in Classical Chinese), so the above code is equivalent to:

吾有一數曰三名之曰「甲」為是「甲」遍吾有一言曰「「問天地好在」」書之云云

More sophisticated examples, such as the Sieve of Eratosthenes, Quicksort, Mandelbrot set, and Tower of Hanoi, can be found in the ./examples folder.

Features

An NLP sharing the grammar of Classical Chinese

Compiles to JavaScript or Python

Turing complete

An online IDE

Examples to get started

InstallationThe Compiler

Clone the repo, (OR simply download ./build/wenyan.js and set its executable bit using the terminal command chmod +x wenyan.js). Then run ./build/wenyan.js to compile your wenyan souce code to target language. Calling the compiler without arguments prints the help message, reproduced below:

Usage: wenyan [options] [input files]
Options:
--eval    -e <string>  : Give a string instead of a file (default: `')
--exec    -x <boolean> : Execute output (default: `false')
--inspect -i <boolean> : Interactive REPL (default: `false')
--lang    -l <string>  : Language: js/py (default: `js')
--log        <string>  : Log file (default: `/dev/null')
--output  -o <string>  : Output file (default: `/dev/stdout')
--roman   -r <boolean> : Romanize identifiers (default: `true')

Try building the included examples first, e.g.:

分享到:

版權與免責聲明:

凡未注明"稿件來源"的內容均為轉載稿,本網轉載出于傳遞更多信息的目的;如轉載稿涉及版權問題,請作者聯系我們,同時對于用戶評論等信息,本網并不意味著贊同其觀點或證實其內容的真實性;


本文地址:http://www.1536221.live/news/2019/12/31/62349023.html

轉載本站原創文章請注明來源:草根網

行業聚焦

高通驍龍7c/8c/8cx計算平臺發布:為始終在線的PC打造

IT之家12月6日消息 在夏威夷舉辦的驍龍技術峰會上,高通宣布擴展高通驍龍計算平臺產品組合,以持久續航、高速蜂窩連接以及AI加速性能,賦能無風扇、設計輕薄的現代...[詳細]

CoralGlobal珊瑚跨境結算

北海市副市長卓英子一行蒞臨CoralGlobal,未來或共同開拓東盟市場 11月15日,廣西北海市副市長卓英子、金融辦主任周柯伊、紅樹林現代金融產業城董事長余邦...[詳細]

美團未來五年將助力商家打造“下一代門店” 更好服務億萬用戶

美團高級副總裁兼到家事業群總裁王莆中今天表示,“未來5年,外賣產業發展重心將由需求側轉向供給側。為此,美團將助力千萬商家打造‘下一代門店’,從而更好服務億萬用戶...[詳細]

2020年5款新iPhone機型參數曝光 399美元起

據外媒傳出的消息稱,蘋果公司將在明年發布5款新的iPhone機型,并且曝光了相關參數。由于iPhone 11系列并沒有支持5G,使得iPhone在5G市場失去先...[詳細]

曉董說財鴻達轉債木森轉債值得申購嗎

大家好,我是曉董說財的曉董。今日,有4只轉債能夠申購,也便是明陽轉債、仙鶴轉債、鴻達轉債、木森轉債。上星期六,曉董介紹了明陽轉債、仙鶴轉債,今日介紹后兩個。鴻達...[詳細]

科技趨勢

更多

5G手機誰在用?在哪用?這里有一份5G手機報告待查收

 

自8月5日第一臺5G手機上市以來,5G手機逐漸走進日常生活,這也使得“5G手機”成為了2019的年度熱詞。5G手機哪些機...[詳細]

支付寶正式開通工業互聯網標識服務功能

 

原標題:支付寶正式開通工業互聯網標識服務功能 來源:中國信通院通信世界網消息(CWW)2019年12月19日,由中國信息...[詳細]

雪佛蘭暢巡主要配置公布 續航可達410公里

 

近日,雪佛蘭正式公布了純電城際轎跑暢巡的主要配置,在續航方面,可以達到410公里。作為雪佛蘭首款進入國內的純電動車,暢巡...[詳細]

9699元,聯想Y9000X新品上架:i7

 

IT之家11月30日消息 據IT之家網友分享,聯想Y9000X新品現已上架,搭載英特爾i7-9750H處理器,配備32G...[詳細]

PlayStation 25周年:成就了泛娛樂,也成就了索尼

 

在上個世紀的80年代,平井一夫剛從日本國際基督教大學畢業,拿下文學碩士的他在同年加入了索尼與哥倫比亞廣播公司聯合創辦的公...[詳細]

一周排行每月關注
云鼎彩票app靠谱吗